This is one component of an AnalyticalModelSketch, which exists to provide greater granularity over the Analytical Model than at the Element level.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since:
2011
Syntax
C# |
---|
public class AnalyticalModelSketchComponent : IDisposable |
Visual Basic |
---|
Public Class AnalyticalModelSketchComponent _ Implements IDisposable |
Visual C++ |
---|
public ref class AnalyticalModelSketchComponent : IDisposable |
Remarks
This may or may not be a simple one-to-one mapping to ElementIds. For instance, one Element
may be defined by multiple Curve Elements within a Sketch. But another Element may not have
that designation, and the individual curves are not defined by any other Elements within a document.
Inheritance Hierarchy
System..::..Object
Autodesk.Revit.DB.Structure..::..AnalyticalModelSketchComponent
Autodesk.Revit.DB.Structure..::..AnalyticalModelSketchComponent