A class that provides functionality to create temporary graphics in a Revit model.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.1.0)
Since:
2022
Syntax
C# |
---|
public class TemporaryGraphicsManager : IDisposable |
Visual Basic |
---|
Public Class TemporaryGraphicsManager _ Implements IDisposable |
Visual C++ |
---|
public ref class TemporaryGraphicsManager : IDisposable |
Remarks
The graphics created by this class are temporary or transient. They are not subject to undo and are not saved. It's caller's responsiblity to manage their lifetime, creation and destruction, though Revit will destroy all of them when closing the model.
Inheritance Hierarchy
System..::..Object
Autodesk.Revit.DB..::..TemporaryGraphicsManager
Autodesk.Revit.DB..::..TemporaryGraphicsManager