Returns the angle between this vector and the specified vector projected to the specified plane.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.1.0)
Syntax
C# |
---|
public double AngleOnPlaneTo(
XYZ right,
XYZ normal
) |
Visual Basic |
---|
Public Function AngleOnPlaneTo ( _
right As XYZ, _
normal As XYZ _
) As Double |
Visual C++ |
---|
public:
double AngleOnPlaneTo(
XYZ^ right,
XYZ^ normal
) |
Return Value
The real number between 0 and 2*PI equal to the projected angle between the two vectors.
Remarks
Exceptions
See Also