Represents the Autodesk Revit user interface, providing access to
UI customization methods and events.
Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 22.0.0.0 (22.1.1.0)
Syntax
C# |
---|
public class UIControlledApplication |
Visual Basic |
---|
Public Class UIControlledApplication |
Visual C++ |
---|
public ref class UIControlledApplication |
Remarks
This class does not provide access to documents because it is provided to you through the ExternalApplication
OnStartup()/OnShutdown() methods, and those methods are when it is not possible to work with Revit documents.
You can work with documents by getting them from the UIApplication class; that class is obtained from events and
ExternalCommand callbacks.
Inheritance Hierarchy
System..::..Object
Autodesk.Revit.UI..::..UIControlledApplication
Autodesk.Revit.UI..::..UIControlledApplication