Revit 2022.1 API |
FamilyManager..::..DeleteCurrentType Method |
FamilyManager Class See Also |
Remove the current family type.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.1.0)
Syntax
C# |
---|
public void DeleteCurrentType() |
Visual Basic |
---|
Public Sub DeleteCurrentType |
Visual C++ |
---|
public: void DeleteCurrentType() |
Remarks
If successfully removed, the first available type will become the current type,
otherwise an exception with failure information will be thrown.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when there is only one family type in current document. |