AllRuleParametersApplicable Method (ElementFilter)
Checks that the parameters of the rules used by the given ElementFilter are valid for this filter's categories.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since:  2019

Syntax

C#
public bool AllRuleParametersApplicable(
	ElementFilter elementFilter
)
Visual Basic
Public Function AllRuleParametersApplicable ( _
	elementFilter As ElementFilter _
) As Boolean
Visual C++
public:
bool AllRuleParametersApplicable(
	ElementFilter^ elementFilter
)

Parameters

elementFilter
Type: Autodesk.Revit.DB..::..ElementFilter
The ElementFilter containing the rules to check.

Return Value

True if all the parameters of the given rules are valid for this filter, otherwise false.

Exceptions

ExceptionCondition
Autodesk.Revit.Exceptions..::..ArgumentNullException A non-optional argument was null

See Also