Revit 2022 API |
AnalysisDisplayStyle..::..CreateAnalysisDisplayStyle Method (Document, String, AnalysisDisplayDeformedShapeSettings, AnalysisDisplayColorSettings, AnalysisDisplayLegendSettings) |
AnalysisDisplayStyle Class See Also |
Factory method - creates analysis display style object of type Deformed Shape for the given document.
Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since:
2013
Syntax
C# |
---|
public static AnalysisDisplayStyle CreateAnalysisDisplayStyle( Document document, string name, AnalysisDisplayDeformedShapeSettings deformedShapeSettings, AnalysisDisplayColorSettings colorSettings, AnalysisDisplayLegendSettings legendSettings ) |
Visual Basic |
---|
Public Shared Function CreateAnalysisDisplayStyle ( _ document As Document, _ name As String, _ deformedShapeSettings As AnalysisDisplayDeformedShapeSettings, _ colorSettings As AnalysisDisplayColorSettings, _ legendSettings As AnalysisDisplayLegendSettings _ ) As AnalysisDisplayStyle |
Visual C++ |
---|
public: static AnalysisDisplayStyle^ CreateAnalysisDisplayStyle( Document^ document, String^ name, AnalysisDisplayDeformedShapeSettings^ deformedShapeSettings, AnalysisDisplayColorSettings^ colorSettings, AnalysisDisplayLegendSettings^ legendSettings ) |
Parameters
- document
- Type: Autodesk.Revit.DB..::..Document
Document for which analysis display style object is created.
- name
- Type: System..::..String
Name of the analysis display style within the %document%.
- deformedShapeSettings
- Type: Autodesk.Revit.DB.Analysis..::..AnalysisDisplayDeformedShapeSettings
Deformed Shape settings for the style.
- colorSettings
- Type: Autodesk.Revit.DB.Analysis..::..AnalysisDisplayColorSettings
Color settings for the style.
- legendSettings
- Type: Autodesk.Revit.DB.Analysis..::..AnalysisDisplayLegendSettings
Legend settings for the style.
Return Value
New analysis display style object.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null |
Autodesk.Revit.Exceptions..::..ArgumentsInconsistentException | document is a family. -or- name is not unique in document. |