Revit 2022 API |
AnalysisDisplayStyle..::..SetLegendSettings Method |
AnalysisDisplayStyle Class See Also |
Set legend settings object for the style.
Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since:
2011
Syntax
C# |
---|
public void SetLegendSettings( AnalysisDisplayLegendSettings legendSettings ) |
Visual Basic |
---|
Public Sub SetLegendSettings ( _ legendSettings As AnalysisDisplayLegendSettings _ ) |
Visual C++ |
---|
public: void SetLegendSettings( AnalysisDisplayLegendSettings^ legendSettings ) |
Parameters
- legendSettings
- Type: Autodesk.Revit.DB.Analysis..::..AnalysisDisplayLegendSettings
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null |