The exception that is thrown when referencing an object that is no longer valid.
Namespace: Autodesk.Revit.Exceptions
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Syntax
C# |
---|
[SerializableAttribute] public class InvalidObjectException : InvalidOperationException |
Visual Basic |
---|
<SerializableAttribute> _ Public Class InvalidObjectException _ Inherits InvalidOperationException |
Visual C++ |
---|
[SerializableAttribute] public ref class InvalidObjectException : public InvalidOperationException |
Remarks
The object may no longer exist for many reasons:
- The object was explicitly deleted from the database.
- A change to other database items caused the item to be automatically deleted from the database.
- The object no longer exists as its creation was undone (by rolling a transaction back).
Inheritance Hierarchy
System..::..Object
System..::..Exception
Autodesk.Revit.Exceptions..::..ApplicationException
Autodesk.Revit.Exceptions..::..InvalidOperationException
Autodesk.Revit.Exceptions..::..InvalidObjectException
System..::..Exception
Autodesk.Revit.Exceptions..::..ApplicationException
Autodesk.Revit.Exceptions..::..InvalidOperationException
Autodesk.Revit.Exceptions..::..InvalidObjectException