Represents a proxy class exposing the interfaces needed to access details of a subregion.
Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since:
2014
Syntax
C# |
---|
public class SiteSubRegion : IDisposable |
Visual Basic |
---|
Public Class SiteSubRegion _ Implements IDisposable |
Visual C++ |
---|
public ref class SiteSubRegion : IDisposable |
Remarks
In the Revit database, both TopographySurface elements and subregion elements are represented by the same TopographySurface element subclass.
In the Revit API, this SiteSubRegion class exists to separate the interfaces for subregions from those of topography surfaces.
Inheritance Hierarchy
System..::..Object
Autodesk.Revit.DB.Architecture..::..SiteSubRegion
Autodesk.Revit.DB.Architecture..::..SiteSubRegion