ElementQuickFilter Class
A base class for a type of filter that operates on element records.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since:  2011

Syntax

C#
public class ElementQuickFilter : ElementFilter
Visual Basic
Public Class ElementQuickFilter _
	Inherits ElementFilter
Visual C++
public ref class ElementQuickFilter : public ElementFilter

Remarks

Quick filters operate only on the ElementRecord, a low-memory class which has a limited interface to read element properties. Elements which are rejected by a quick filter will not be expanded in memory.

Inheritance Hierarchy

See Also