Revit 2022 API |
MultistoryStairs..::..Unpin Method |
MultistoryStairs Class See Also |
Removes a particular story of the stairs (identified by its base level id) from a stairs group.
Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since:
2018
Syntax
C# |
---|
public Stairs Unpin( ElementId levelId ) |
Visual Basic |
---|
Public Function Unpin ( _ levelId As ElementId _ ) As Stairs |
Visual C++ |
---|
public: Stairs^ Unpin( ElementId^ levelId ) |
Parameters
- levelId
- Type: Autodesk.Revit.DB..::..ElementId
The base level id. If the level id belongs to the base level of a unpinned stairs element, it returns the stairs id directly.
Return Value
The unpinned stairs element.
Remarks
If the story at the given level is in a group, it will separate an individual stairs element from the group with "unpinned" status. Changes you make to the returned stairs element will not affect any other stairs.
If the story of stairs is already an individual stairs element, the status will be changed to "unpinned".
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | There is no stairs instance at the given base levelId. |
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null |