Revit 2023 API |
LocationCurve..::..JoinType Property |
LocationCurve Class See Also |
Get/change the type of the join at the specified end.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 23.0.0.0 (23.1.0.0)
Syntax
C# |
---|
public JoinType this[ int end ] { get; set; } |
Visual Basic |
---|
Public Property JoinType ( _ end As Integer _ ) As JoinType Get Set |
Visual C++ |
---|
public: property JoinType JoinType[int end] { JoinType get (int end); void set (int end, JoinType value); } |
Parameters
- end
- Type: System..::..Int32
The end of the location curve driver under question.
Remarks
This property allows to get join type of wall and concrete beam and to set wall's join type.
The new join type is expected to be different from the current one for this end.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..InvalidOperationException | The element is neither a wall nor a concrete beam when it tries to get the property. The element is not a wall when it tries to set the property. |
Autodesk.Revit.Exceptions..::..InvalidOperationException | A failure occurred while attempting to set the new type. |