Revit 2023 API |
FormatOptions Constructor (ForgeTypeId, ForgeTypeId) |
FormatOptions Class See Also |
Creates a new FormatOptions object that represents custom formatting.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 23.0.0.0 (23.1.0.0)
Since:
2014
Syntax
C# |
---|
public FormatOptions( ForgeTypeId unitTypeId, ForgeTypeId symbolTypeId ) |
Visual Basic |
---|
Public Sub New ( _ unitTypeId As ForgeTypeId, _ symbolTypeId As ForgeTypeId _ ) |
Visual C++ |
---|
public: FormatOptions( ForgeTypeId^ unitTypeId, ForgeTypeId^ symbolTypeId ) |
Parameters
- unitTypeId
- Type: Autodesk.Revit.DB..::..ForgeTypeId
Identifier of the unit to display.
- symbolTypeId
- Type: Autodesk.Revit.DB..::..ForgeTypeId
Identifier of the symbol with which to render the unit.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | symbolTypeId is not a valid symbol for unitTypeId. |
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null |