Geometric representation of an element.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 23.0.0.0 (23.1.0.0)
Syntax
C# |
---|
public class GeometryElement : GeometryObject, IEnumerable<GeometryObject> |
Visual Basic |
---|
Public Class GeometryElement _ Inherits GeometryObject _ Implements IEnumerable(Of GeometryObject) |
Visual C++ |
---|
public ref class GeometryElement : public GeometryObject, IEnumerable<GeometryObject^> |
Remarks
This class contains geometric primitives that are generated from the
parametric description of the element. The member geometric primitives can be obtained
directly from this object using the capabilities of IEnumerable.
Inheritance Hierarchy
System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..GeometryObject
Autodesk.Revit.DB..::..GeometryElement
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..GeometryObject
Autodesk.Revit.DB..::..GeometryElement