Revit 2023 API |
FormattedText..::..GetUnderlineStatus Method (TextRange) |
FormattedText Class See Also |
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 23.0.0.0 (23.1.0.0)
Since:
2017
Syntax
C# |
---|
public FormatStatus GetUnderlineStatus( TextRange textRange ) |
Visual Basic |
---|
Public Function GetUnderlineStatus ( _ textRange As TextRange _ ) As FormatStatus |
Visual C++ |
---|
public: FormatStatus GetUnderlineStatus( TextRange^ textRange ) |
Parameters
- textRange
- Type: Autodesk.Revit.DB..::..TextRange
The given text range.
Return Value
The format status of underline on characters FormatStatus.
Remarks
This function only returns All or None if the text contains one character.
The given text range should not be empty.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | This text range is empty. -or- This start index of this text range is not within the text range identifying the entire text. -or- The end of this text range is not within the text range identifying the entire text. |
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null |