Autodesk.Revit.UI.Selection Namespace
 

Classes

  ClassDescription
Public classPickedBox
A class that contains two XYZ points representing the pick box on the screen.
Public classSelectableInViewFilter
A filter that passes elements that are selectable in the given view.
Public classSelection
Contains the current user selection of elements within the project.

Interfaces

  InterfaceDescription
Public interfaceISelectionFilter
An interface that provides the ability to filter objects during a selection operation.

Enumerations

  EnumerationDescription
Public enumerationObjectSnapTypes
This enumerated type contains object snap types allowed to be set during PickPoint operations.
Public enumerationObjectType
This enumerated type contains object types allowed to be selected during selection operations.
Public enumerationPickBoxStyle
The enum that controls the style of the pick box.