Revit 2023 API |
FormatOptions..::..GetValidSymbols Method |
FormatOptions Class See Also |
Gets the identifiers of all valid symbols for the unit in this FormatOptions.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 23.0.0.0 (23.1.0.0)
Since:
2014
Syntax
C# |
---|
public IList<ForgeTypeId> GetValidSymbols() |
Visual Basic |
---|
Public Function GetValidSymbols As IList(Of ForgeTypeId) |
Visual C++ |
---|
public: IList<ForgeTypeId^>^ GetValidSymbols() |
Return Value
Identifiers of the valid symbols.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..InvalidOperationException | UseDefault is true in this FormatOptions. |