An object that represents a wall foundation element.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 23.0.0.0 (23.1.0.0)
Since:
2016
Syntax
C# |
---|
public class WallFoundation : HostObject |
Visual Basic |
---|
Public Class WallFoundation _ Inherits HostObject |
Visual C++ |
---|
public ref class WallFoundation : public HostObject |
Examples

public void GetInfo_WallFoundation(WallFoundation wallFoundation) { string message = "Wall Foundation : "; // Get Footing type name Document doc = wallFoundation.Document; message += "\nFoundation type name is : " + doc.GetElement(wallFoundation.GetTypeId()).Name; TaskDialog.Show("Revit",message); }

Public Sub GetInfo_WallFoundation(wallFoundation As WallFoundation) Dim message As String = "Wall Foundation : " ' Get Footing type name Dim doc As Document = wallFoundation.Document message += vbLf & "Foundation type name is : " & Convert.ToString(doc.GetElement(wallFoundation.GetTypeId()).Name) TaskDialog.Show("Revit", message) End Sub
Inheritance Hierarchy
System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..HostObject
Autodesk.Revit.DB..::..WallFoundation
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..HostObject
Autodesk.Revit.DB..::..WallFoundation