The exception thrown when Revit cancels a background operation. Third-party
developers are not expected to catch and handle this exception. Instead, if allowed
to propagate back to Revit code, it will be handled by Revit.
Namespace: Autodesk.Revit.Exceptions
Assembly: RevitAPI (in RevitAPI.dll) Version: 23.0.0.0 (23.1.0.0)
Since: 2017
Syntax
C# |
---|
[SerializableAttribute] public class BackgroundTaskCancelledException : ApplicationException |
Visual Basic |
---|
<SerializableAttribute> _ Public Class BackgroundTaskCancelledException _ Inherits ApplicationException |
Visual C++ |
---|
[SerializableAttribute] public ref class BackgroundTaskCancelledException : public ApplicationException |
Inheritance Hierarchy
System..::..Object
System..::..Exception
Autodesk.Revit.Exceptions..::..ApplicationException
Autodesk.Revit.Exceptions..::..BackgroundTaskCancelledException
System..::..Exception
Autodesk.Revit.Exceptions..::..ApplicationException
Autodesk.Revit.Exceptions..::..BackgroundTaskCancelledException