Retrieves the number of interior or exterior shell layers.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 23.0.0.0 (23.1.0.0)
Syntax
Visual Basic |
---|
Public Function GetNumberOfShellLayers ( _
shellLayerType As ShellLayerType _
) As Integer |
Visual C++ |
---|
public:
int GetNumberOfShellLayers(
ShellLayerType shellLayerType
) |
Parameters
- shellLayerType
- Type: Autodesk.Revit.DB..::..ShellLayerType
If ShellLayerType.Exterior return the number of exterior shell layers (or top shell layers for a roof, floor, or ceiling type).
If ShellLayerType.Interior return the number of interior shell layers (or bottom shell layers for a roof, floor, or ceiling type).
Return Value
The number of shell layers in the interior or exterior shell, as specified by shellLayerType.
Remarks
Exceptions
See Also