An affine transform of 1D Euclidean space.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 23.0.0.0 (23.1.0.0)
Since:
2021
Syntax
C# |
---|
public class Transform1D : IDisposable |
Visual Basic |
---|
Public Class Transform1D _ Implements IDisposable |
Visual C++ |
---|
public ref class Transform1D : IDisposable |
Remarks
An affine transform is a linear transform plus a translation (which may be zero).
1D space is tranformed according to the following formula: t -> A*t + B where A and B are constants.
Some functions only accept certain kinds of transform (e.g., rigid motion, conformal, non-singular, etc.).
Inheritance Hierarchy
System..::..Object
Autodesk.Revit.DB..::..Transform1D
Autodesk.Revit.DB..::..Transform1D