DocumentDifference represents the difference (including added elements, modified elements and deleted elements) of a Revit model between different DocumentVersion of the model.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 23.0.0.0 (23.1.0.0)
Since:
2023
Syntax
C# |
---|
public class DocumentDifference : IDisposable |
Visual Basic |
---|
Public Class DocumentDifference _ Implements IDisposable |
Visual C++ |
---|
public ref class DocumentDifference : IDisposable |
Remarks
For workshared models, DocumentDifference may contain all the added elements, modified elements and deleted elements.
For non-workshared models, deleted elements are not tracked, so this object may only contain added elements and modified elements.
Inheritance Hierarchy
System..::..Object
Autodesk.Revit.DB..::..DocumentDifference
Autodesk.Revit.DB..::..DocumentDifference