Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 23.0.0.0 (23.1.0.0)
Since:
2014
Syntax
C# |
---|
public class RelinquishOptions : IDisposable |
Visual Basic |
---|
Public Class RelinquishOptions _ Implements IDisposable |
Visual C++ |
---|
public ref class RelinquishOptions : IDisposable |
Remarks
The settings correspond to the checkboxes in the Synchronize with Central dialog in the section "After synchronizing, relinquish the following worksets and elements:".
An element can be owned (reflected in the "Edited By" parameter) either by being checked out ("borrowed") or by belonging to a checked out workset.
Relinquishing a workset will relinquish all its unmodified elements that the current user owns.
The subtle interactions between checking out elements and checking out worksets are beyond the scope of the documentation for this class. But as an example, if a wall is borrowed (explicitly checked out) and then its workset is checked out, then the wall is no longer considered borrowed because the workset ownership implicitly grants ownership of all elements in the workset (except elements borrowed by other users).
Inheritance Hierarchy
Autodesk.Revit.DB..::..RelinquishOptions