Revit 2023 API |
ImageTypeStatus Enumeration |
See Also |
Indicates the current state of the contents of the ImageType.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 23.0.0.0 (23.1.0.0)
Since:
2021
Since:
2021
Syntax
C# |
---|
public enum ImageTypeStatus |
Visual Basic |
---|
Public Enumeration ImageTypeStatus |
Visual C++ |
---|
public enum class ImageTypeStatus |
Members
Member name | Description |
---|---|
Unknown | The linked image has not yet been loaded. No image is available. This status is only returned before the document is fully opened. |
Loaded | The linked image was successfully loaded. |
FailedToLoad | The linked image could not be loaded from file. Some possible reasons are:
|
Unloaded | The linked images was unloaded by the user. No image is available. |
Imported | The image was imported and is available. |
Generated | The internally created image is available. |