Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 23.0.0.0 (23.1.0.0)
Since:
2012
Syntax
C# |
---|
public class ExtrusionAnalyzer : IDisposable |
Visual Basic |
---|
Public Class ExtrusionAnalyzer _ Implements IDisposable |
Visual C++ |
---|
public ref class ExtrusionAnalyzer : IDisposable |
Remarks
An instance of this class is a single-time use class which should be supplied a solid geometry, a plane, and a direction. The utility will calculate a base boundary parallel to the input plane which is the outer boundary of the shadow cast by the solid onto the input plane and along the extrusion direction.
After the extrusion has been calculated, the class permits a second step analysis to identify all faces from the original geometry which do not align with the faces of the calculated extrusion.
This utility works best for geometry which are at least somewhat "extrusion-like", for example, the geometry of a wall which may or may not be affected by end joins, floor joins, roof joins, openings cut by windows and doors, or other modifications.
Inheritance Hierarchy
Autodesk.Revit.DB..::..ExtrusionAnalyzer