Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 23.0.0.0 (23.1.0.0)
Since:
2018
Syntax
C# |
---|
public class CADLinkOperations : LinkOperations |
Visual Basic |
---|
Public Class CADLinkOperations _ Inherits LinkOperations |
Visual C++ |
---|
public ref class CADLinkOperations : public LinkOperations |
Remarks
The class owns single-method interfaces which are used as callbacks to perform specific operations on DWG link external resources.
An empty CADLinkOperations instance is passed to an IExternalResourceServer (inside an ExternalResourceServerExtensions object) via the GetTypeSpecificServerOperations method. The server provider can then add their own implemented interface objects to the CADLinkOperations, thus making them available to Revit to use as callbacks.
Supporting these additional, type-specific operations is not absolutely required, but is strongly recommended in order for users to be able to perform all the same operations they would with locally-accessed links.