A record in the Revit database representing an element.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 23.0.0.0 (23.1.0.0)
Since:
2011
Syntax
C# |
---|
public class ElementRecord : IDisposable |
Visual Basic |
---|
Public Class ElementRecord _ Implements IDisposable |
Visual C++ |
---|
public ref class ElementRecord : IDisposable |
Remarks
The record is used to extract basic information about an element before
the element is fully expanded in memory.
Inheritance Hierarchy
System..::..Object
Autodesk.Revit.DB..::..ElementRecord
Autodesk.Revit.DB..::..ElementRecord