Returns set of elements that were deleted from the document.
This set is mutually exclusive of elements returned by getAddedElementIds() and getModifiedElementIds().
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 23.0.0.0 (23.1.0.0)
Since:
2011
Syntax
C# |
---|
public ICollection<ElementId> GetDeletedElementIds() |
Visual Basic |
---|
Public Function GetDeletedElementIds As ICollection(Of ElementId) |
Visual C++ |
---|
public:
ICollection<ElementId^>^ GetDeletedElementIds() |
Return Value
Set of elements that were deleted from the document and triggered the call to execute()
Note: This will only return elements if the trigger registered for the associated updater
contains the ChangeType returned by Element::getChangeTypeElementDeletion()
See Also