The exception thrown when a central model is opened directly and its copy in the session is
outdated. If the operation is supported for local files, first resave as local, and try again.
Namespace: Autodesk.Revit.Exceptions
Assembly: RevitAPI (in RevitAPI.dll) Version: 23.0.0.0 (23.1.0.0)
Since: 2014
Syntax
C# |
---|
[SerializableAttribute] public class OutdatedDirectlyOpenedCentralException : CentralModelException |
Visual Basic |
---|
<SerializableAttribute> _ Public Class OutdatedDirectlyOpenedCentralException _ Inherits CentralModelException |
Visual C++ |
---|
[SerializableAttribute] public ref class OutdatedDirectlyOpenedCentralException : public CentralModelException |
Inheritance Hierarchy
System..::..Object
System..::..Exception
Autodesk.Revit.Exceptions..::..ApplicationException
Autodesk.Revit.Exceptions..::..CentralModelException
Autodesk.Revit.Exceptions..::..OutdatedDirectlyOpenedCentralException
System..::..Exception
Autodesk.Revit.Exceptions..::..ApplicationException
Autodesk.Revit.Exceptions..::..CentralModelException
Autodesk.Revit.Exceptions..::..OutdatedDirectlyOpenedCentralException