An interface class which provide the callback for family load options.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 23.0.0.0 (23.1.0.0)
Syntax
C# |
---|
public interface IFamilyLoadOptions |
Visual Basic |
---|
Public Interface IFamilyLoadOptions |
Visual C++ |
---|
public interface class IFamilyLoadOptions |
Remarks
If the family is not loaded, or if the family is loaded but unchanged, the situation will never trigger and OnFamilyFound(Boolean, Boolean%) and OnSharedFamilyFound(Family, Boolean, FamilySource%, Boolean%) will not be called. Only if the family is loaded and changed should the interface methods be called.