The sketch plane the curve element lies in.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 23.0.0.0 (23.1.0.0)
Syntax
Visual Basic |
---|
Public Overridable Property SketchPlane As SketchPlane
Get
Set |
Remarks
Exceptions
Exception | Condition |
---|
Autodesk.Revit.Exceptions..::..ArgumentNullException |
Thrown if the argument is nullNothingnullptra null reference (Nothing in Visual Basic).
|
Autodesk.Revit.Exceptions..::..InvalidOperationException |
Thrown if the CurveElement is CurveByPoints or belongs to a Path3d element. -- or --
Thrown if the sketch plane is set on a DetailCurve. --or--
Thrown if the sketch plane is not parallel to the existing plane. -- or --
Thrown if the sketch plane is not suitable. -- or --
Thrown if the CurveElement belongs to a sketch-based element. -- or --
Thrown if modifying the sketch plane is not allowed. -- or --
Thrown if the CurveElement cannot be moved out of its sketch plane.
|
See Also