Revit 2023 API |
FailuresAccessor..::..IsActive Method |
FailuresAccessor Class See Also |
Method allows to check if this instance of the accessor is currently active.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 23.0.0.0 (23.1.0.0)
Since:
2011
Syntax
C# |
---|
public bool IsActive() |
Visual Basic |
---|
Public Function IsActive As Boolean |
Visual C++ |
---|
public: bool IsActive() |
Return Value
True if this instance is currently active and can be used.
Remarks
Generally, this instance is active when it is passed to any of interfaces used in the process of failure resolution,
and becomes inactive after returning control to Revit.
The only special case is if failures processor returns WaitForUserInput,
in which case document stays in the FailureMode and instance of failures accessor stays active till FailureMode is ended.