Increments the iterator to the next element id passing the filter.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 23.0.0.0 (23.1.0.0)
Since:
2011
Syntax
C# |
---|
public virtual bool MoveNext() |
Visual Basic |
---|
Public Overridable Function MoveNext As Boolean |
Visual C++ |
---|
public:
virtual bool MoveNext() |
Return Value
True if there is another available element id passing the filter in this iterator.
False if the iterator has completed all available element ids.
Exceptions
Exception | Condition |
---|
Autodesk.Revit.Exceptions..::..InvalidOperationException |
The FilteredElementCollector that yielded this iterator has been reset by another operation.
No further iteration is permitted with this iterator.
-or-
The iterator cannot proceed due to changes made to the Element table in Revit's database (typically, this can be the result of an Element deletion).
|
See Also