Defines the measurement parameters necessary to create a point at a specific location on a curve.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 23.0.0.0 (23.1.0.0)
Since:
2012
Syntax
C# |
---|
public class PointLocationOnCurve : IDisposable |
Visual Basic |
---|
Public Class PointLocationOnCurve _ Implements IDisposable |
Visual C++ |
---|
public ref class PointLocationOnCurve : IDisposable |
Remarks
The class will store the following and provides functions to deal with them:
- The user visible Measurement Type (driving parameter type).
- The corresponding measurement value (driving parameter).
- MeasureFrom that tells from where the (driving parameter) measurement is calculated.
Inheritance Hierarchy
System..::..Object
Autodesk.Revit.DB..::..PointLocationOnCurve
Autodesk.Revit.DB..::..PointLocationOnCurve