This class represents a triangle in a TriangulatedShellComponent object. The triangle is
defined by its vertices, which are specified by their indices in the
TriangulatedShellComponent's array of vertices.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 23.0.0.0 (23.1.0.0)
Since:
2013
Syntax
C# |
---|
public class TriangleInShellComponent : IDisposable |
Visual Basic |
---|
Public Class TriangleInShellComponent _ Implements IDisposable |
Visual C++ |
---|
public ref class TriangleInShellComponent : IDisposable |
Remarks
A TriangulatedShellComponent stores an array of TriangleInShellComponent objects
representing the triangles of the triangulation. An external class is used
because the API does not allow the use of a triple of integers. Note that a
TriangleInShellComponent must only be used in the context of a single, fixed
TriangulatedShellComponent.
Inheritance Hierarchy
System..::..Object
Autodesk.Revit.DB..::..TriangleInShellComponent
Autodesk.Revit.DB..::..TriangleInShellComponent