Revit 2024 API |
Document..::..GetHashCode Method |
Document Class See Also |
Gets the hash code of this document instance.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Syntax
C# |
---|
public override int GetHashCode() |
Visual Basic |
---|
Public Overrides Function GetHashCode As Integer |
Visual C++ |
---|
public: virtual int GetHashCode() override |
Remarks
The hash code is the same for document instances that represent the same document currently opened in the Revit session.
The hash code is generated when a Revit file is opened or created in session.
If the same Revit file is opened later (in the same session or a different session) the hash code will not be the same.