Moves the selected analytical spaces from the identified zone equipment to another target zone equipment.
Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:
2020.1
Syntax
Visual Basic |
---|
Public Shared Sub MoveSpaceToEquipment ( _
document As Document, _
analyticalSpaceSet As ISet(Of ElementId), _
originalZoneEquipmentId As ElementId, _
targetZoneEquipmentId As ElementId _
) |
Visual C++ |
---|
public:
static void MoveSpaceToEquipment(
Document^ document,
ISet<ElementId^>^ analyticalSpaceSet,
ElementId^ originalZoneEquipmentId,
ElementId^ targetZoneEquipmentId
) |
Parameters
- document
- Type: Autodesk.Revit.DB..::..Document
The document where the zone equipment and the analytical spaces exist.
- analyticalSpaceSet
- Type: System.Collections.Generic..::..ISet<(Of <(<'ElementId>)>)>
The specified analytical spaces to move.
- originalZoneEquipmentId
- Type: Autodesk.Revit.DB..::..ElementId
The original equipment where the analytical spaces will be removed. If passing invalidElementId, the existing zone equipment is not removed.
- targetZoneEquipmentId
- Type: Autodesk.Revit.DB..::..ElementId
The target zone equipment where the analytical spaces will be associated. If passing invalidElementId, the analytical spaces will not be assigned to any new zone equipment.
Exceptions
See Also