Represents a specific type of roof.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Syntax
C# |
---|
public class RoofType : HostObjAttributes |
Visual Basic |
---|
Public Class RoofType _ Inherits HostObjAttributes |
Visual C++ |
---|
public ref class RoofType : public HostObjAttributes |
Remarks
All roof type objects available in the project can be retrieved from the Document object
via the RoofTypes property. Every Roof object has a RoofType property that returns a
RoofType object representing the type. This same RoofType property can also be used to
change the type of the roof by setting it to a different type.
Inheritance Hierarchy
System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..ElementType
Autodesk.Revit.DB..::..HostObjAttributes
Autodesk.Revit.DB..::..RoofType
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..ElementType
Autodesk.Revit.DB..::..HostObjAttributes
Autodesk.Revit.DB..::..RoofType