Revit 2024 API |
FamilyInstance..::..StructuralMaterialType Property |
FamilyInstance Class See Also |
This property returns the physical material from which the instance is made.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Syntax
C# |
---|
public StructuralMaterialType StructuralMaterialType { get; } |
Visual Basic |
---|
Public ReadOnly Property StructuralMaterialType As StructuralMaterialType Get |
Visual C++ |
---|
public: property StructuralMaterialType StructuralMaterialType { StructuralMaterialType get (); } |
Remarks
Values of this property can be Steel, Concrete, Wood or some other material.
Different from Revit materials that geometry really consists of, this property is a family parameter
defining family behavior and can not be set per instance. Its value is the same with the type of the
instance's family. For example, the instances of different kind of column families(Steel, Concrete or
Wood) have different material values and can't be changed int the UI or RevitAPI.