Revit 2024 API |
Document..::..MakeTransientElements Method |
Document Class See Also |
This method encapsulates the process of creating transient elements in the document.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Syntax
C# |
---|
public void MakeTransientElements( ITransientElementMaker maker ) |
Visual Basic |
---|
Public Sub MakeTransientElements ( _ maker As ITransientElementMaker _ ) |
Visual C++ |
---|
public: void MakeTransientElements( ITransientElementMaker^ maker ) |
Parameters
- maker
- Type: Autodesk.Revit.DB..::..ITransientElementMaker
An instance of a class that implements the ITransientElementMaker interface. The maker will be called to create element(s) which would become transient.
Remarks
The method establishes a context within which transient elements will be created and then invokes the given maker object to create the elements. For more information refer to the IsTransient method.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null |
Autodesk.Revit.Exceptions..::..InvalidOperationException | This Document has an open editing transaction and is accepting changes. -or- This Document is read-only: It cannot be modified. |