Revit 2024 API |
DirectShapeType..::..AddExternallyTaggedGeometry Method |
DirectShapeType Class See Also |
Adds the externally tagged geometry object to the DirectShapeType.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:
2022
Syntax
C# |
---|
public void AddExternallyTaggedGeometry( ExternallyTaggedGeometryObject externallyTaggedGeometry ) |
Visual Basic |
---|
Public Sub AddExternallyTaggedGeometry ( _ externallyTaggedGeometry As ExternallyTaggedGeometryObject _ ) |
Visual C++ |
---|
public: void AddExternallyTaggedGeometry( ExternallyTaggedGeometryObject^ externallyTaggedGeometry ) |
Parameters
- externallyTaggedGeometry
- Type: Autodesk.Revit.DB..::..ExternallyTaggedGeometryObject
The externally tagged geometry that should be added to the DirectShapeType.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | The input shape does not satisfy DirectShapeType validation criteria. -or- The input geometry does not have a permitted usage. -or- The externallyTaggedGeometry has already been added to this DirectShapeType. |
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null |