Represents electrical wire material type definition information of wire type.
Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Syntax
C# |
---|
public class WireMaterialType : ElementType |
Visual Basic |
---|
Public Class WireMaterialType _ Inherits ElementType |
Visual C++ |
---|
public ref class WireMaterialType : public ElementType |
Remarks
All the other properties of wire type are based on wire material type.
Only the wire material types which are retrieved from ElectricalSetting can work well, so don't retrieve it from Revit project directly.
Inheritance Hierarchy
System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..ElementType
Autodesk.Revit.DB.Electrical..::..WireMaterialType
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..ElementType
Autodesk.Revit.DB.Electrical..::..WireMaterialType