Revit 2024 API |
Document..::..GetSubelement Method (Reference) |
Document Class See Also |
Gets the subelement referenced by the input reference.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:
2018
Syntax
C# |
---|
public Subelement GetSubelement( Reference reference ) |
Visual Basic |
---|
Public Function GetSubelement ( _ reference As Reference _ ) As Subelement |
Visual C++ |
---|
public: Subelement^ GetSubelement( Reference^ reference ) |
Parameters
- reference
- Type: Autodesk.Revit.DB..::..Reference
The reference that identifies element or subelement.
Return Value
The subelement referenced by the input argument.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | reference does not identify a valid element or subelement. |
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null |