Revit 2024 API |
GeometryObject..::..GraphicsStyleId Property |
GeometryObject Class Example See Also |
The ElementId of the GeometryObject's GraphicsStyle
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012
Syntax
Remarks
This property provides the id of the GraphicsStyle assigned to the GeometryObject.
This can be used to find the category of the object.
Examples
![](/static/chm/revit/icons/CopyCode.gif)
// find the name of the GraphicsSytleCategory for every geometric primitive in a family instance Options options = app.Create.NewGeometryOptions(); GeometryElement geomElem = element.get_Geometry(options); foreach (GeometryObject geomObj in geomElem) { GeometryInstance geomInst = geomObj as GeometryInstance; if (geomInst != null) { foreach (Object obj in geomInst.SymbolGeometry) { GeometryObject geomObject = obj as GeometryObject; GraphicsStyle gStyle = doc.GetElement(geomObject.GraphicsStyleId) as GraphicsStyle; if (gStyle != null) { string gstyleName = gStyle.GraphicsStyleCategory.Name; } } } }
![](/static/chm/revit/icons/CopyCode.gif)
' find the name of the GraphicsSytleCategory for every geometric primitive in a family instance Dim options As Options = app.Create.NewGeometryOptions() Dim geomElem As GeometryElement = element.Geometry(options) For Each geomObj As GeometryObject In geomElem Dim geomInst As GeometryInstance = TryCast(geomObj, GeometryInstance) If geomInst IsNot Nothing Then For Each obj As [Object] In geomInst.SymbolGeometry Dim geomObject As GeometryObject = TryCast(obj, GeometryObject) Dim gStyle As GraphicsStyle = TryCast(doc.GetElement(geomObject.GraphicsStyleId), GraphicsStyle) If gStyle IsNot Nothing Then Dim gstyleName As String = gStyle.GraphicsStyleCategory.Name End If Next End If