Revit 2024 API |
Document..::..GetElement Method (Reference) |
Document Class See Also |
Gets the Element referenced by the input reference.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:
2012
Syntax
C# |
---|
public Element GetElement( Reference reference ) |
Visual Basic |
---|
Public Function GetElement ( _ reference As Reference _ ) As Element |
Visual C++ |
---|
public: Element^ GetElement( Reference^ reference ) |
Parameters
- reference
- Type: Autodesk.Revit.DB..::..Reference
The reference, whose referenced Element will be retrieved from the model.
Return Value
The element referenced by the input argument.Remarks
nullNothingnullptra null reference (Nothing in Visual Basic) will be returned if the input reference doesn't reference to a valid Element.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null |