Adds a reference plane to the DirectShape. The reference plane can either be bounded or unbounded.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:
2022
Syntax
Visual Basic |
---|
Public Sub AddReferencePlane ( _
refPlane As Plane, _
boundingBoxUV As BoundingBoxUV _
) |
Parameters
- refPlane
- Type: Autodesk.Revit.DB..::..Plane
The geometry of the new reference plane.
- boundingBoxUV
- Type: Autodesk.Revit.DB..::..BoundingBoxUV
If boundingBoxUV is set, the resulting reference plane that is added to the DirectShape will be displayed
with those bounds. Note that the specified bounds must not be degenerate.
If boundingBoxUV is not set, reasonable bounds are automatically calculated and applied to the input plane.
The automatic bounds are based on the host direct shape's geometry.
Exceptions
See Also