The exception that is thrown when TransientElementCreationScope is used incorrectly.
Namespace: Autodesk.Revit.Exceptions
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016
Syntax
C# |
---|
[SerializableAttribute] public class TransientElementCreationException : InvalidOperationException |
Visual Basic |
---|
<SerializableAttribute> _ Public Class TransientElementCreationException _ Inherits InvalidOperationException |
Visual C++ |
---|
[SerializableAttribute] public ref class TransientElementCreationException : public InvalidOperationException |
Remarks
The exception would be thrown in the following cases:
- An element that does not support TransientElementCreationScope is being created in the Scope.
- A TransientElementCreationScope is being created while another such scope is already active.
Inheritance Hierarchy
System..::..Object
System..::..Exception
Autodesk.Revit.Exceptions..::..ApplicationException
Autodesk.Revit.Exceptions..::..InvalidOperationException
Autodesk.Revit.Exceptions..::..TransientElementCreationException
System..::..Exception
Autodesk.Revit.Exceptions..::..ApplicationException
Autodesk.Revit.Exceptions..::..InvalidOperationException
Autodesk.Revit.Exceptions..::..TransientElementCreationException