Revit 2024 API |
Element..::..HasPhases Method |
Element Class See Also |
Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:
2013
Syntax
C# |
---|
public bool HasPhases() |
Visual Basic |
---|
Public Function HasPhases As Boolean |
Visual C++ |
---|
public: bool HasPhases() |
Return Value
True if this Element has the properties CreatedPhaseId and DemolishedPhaseId, false otherwise.Remarks
Acts as a validator for setting the properties CreatedPhaseId and DemolishedPhaseId.