The base class for StructuralSection specific classes, designed to provide common parameters and ability to differentiate between different structural section shapes.
Namespace: Autodesk.Revit.DB.Structure.StructuralSections
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:
2015
Syntax
C# |
---|
public class StructuralSection : IEnumerable, IDisposable |
Visual Basic |
---|
Public Class StructuralSection _ Implements IEnumerable, IDisposable |
Visual C++ |
---|
public ref class StructuralSection : IEnumerable, IDisposable |
Inheritance Hierarchy
System..::..Object
Autodesk.Revit.DB.Structure.StructuralSections..::..StructuralSection
Autodesk.Revit.DB.Structure.StructuralSections..::..StructuralSectionRectangular
Autodesk.Revit.DB.Structure.StructuralSections..::..StructuralSectionRound
Autodesk.Revit.DB.Structure.StructuralSections..::..StructuralSection
Autodesk.Revit.DB.Structure.StructuralSections..::..StructuralSectionRectangular
Autodesk.Revit.DB.Structure.StructuralSections..::..StructuralSectionRound